PhpRiot
News Archive
PhpRiot Newsletter
Your Email Address:

More information

Brian Swan's Blog: Running Multiple PHP Versions with IIS

Note: This article was originally published at PHPDeveloper on 24 June 2010.
PHPDeveloper

Brian Swan has a new post to his blog today looking at how to run multiple PHP versions under IIS based on a presentation he gave at the Dutch PHP Conference.

First of all, if you are starting from scratch (i.e. you haven't installed any version of PHP yet), then there is no need to read the rest of my post - you should read this post by Ruslan Yakushev (Program Manager on the IIS team): Multiple PHP Versions on the Same IIS Server.

However, if you have installed at least one version (via the WPI of Windows Installer, then you can benefit from his post. There's a relatively simple three step process to it - deleting an environment variable, restarting and manually installing the other PHP versions. It's the PHPRC environment variable that determines which version IIS looks for.