PhpRiot
News Archive
PhpRiot Newsletter
Your Email Address:

More information

CodeIgniter.com: CodeIgniter 2.0 - Now with more Awesome

Note: This article was originally published at PHPDeveloper on 13 November 2010.
PHPDeveloper

According to a new post to the CodeIgniter.com blog, there's been even more changes in the 2.0 version of the framework - including dropping PHP4 support all together.

A few days ago a new repository popped up on our internal Mercurial server. We're not particularly creative with our naming, so it was simply CodeIgniterNoPhp4. [...] With only a handful of significant changes to its codebase, the release was pushed along. We want to make CI 2 worth its name, so starting today, we're requiring PHP 5.1.6 on our master branch.

They include a few things to watch out for including naming conventions, the change to __construct, a cleaner model object interface and chaining added to the email and validation libraries.