PhpRiot
News Archive
PhpRiot Newsletter
Your Email Address:

More information

WinCache and WordPress plugin upgrade problem

Note: This article was originally published at Planet PHP on 15 April 2011.
Planet PHP

The WinCache extension 1.1 for PHP has been released last year. Since then several customers reported a bug in the extension that prevents WordPress and other PHP applications from performing automatic upgrades or their plugins. This was reported on WordPress forum as well as on WinCache forum.

The new build of WinCache with the fix for this problem is available now at the following location:

https://sourceforge.net/projects/wincache/files/development/

The build 1.2.411 is a release candidate build. Several customers have already verified that this build fixes the problem and is running stable in their environments. Please try it out and let me know if works for you. The things to try and to look for are:

  1. Try to auto-upgrade any of the WordPress plugins;
  2. After installing this build check the Windows Application event log from time to time looking for errors caused by module aophp_wincache.dlla.

If you see any errors while using this build please let me know by leaving a comment here or in WinCache forum or by opening a bug in PECL bug database.